yum update エラー(CentOS7)

たまにはアップデートしておくかとyum updateしたらエラーになってしまった件

yum update –skip-broken でもなおらなかったので
epelリポジトリがあったので、epelをいったん止めてyum updateしたらうまくできた。

/etc/yum.repos.d/epel.repoを直接編集したけど
コマンドだとこんな感じか?

yum --disablerepo=epel update 

 

---> パッケージ perl-Mozilla-CA.noarch 0:20130114-5.el7 を インストール
---> パッケージ systemd-libs.i686 0:219-57.el7 を アップデート
--> 依存性の処理をしています: liblz4.so.1 のパッケージ: systemd-libs-219-57.el7.i686
--> 依存性解決を終了しました。
エラー: パッケージ: systemd-libs-219-57.el7.i686 (base)
             要求: liblz4.so.1
 問題を回避するために --skip-broken を用いることができます。
 これらを試行できます: rpm -Va --nofiles --nodigest

◆LANG=Cの場合

---> Package perl-Mozilla-CA.noarch 0:20130114-5.el7 will be installed
---> Package systemd-libs.i686 0:219-57.el7 will be an update
--> Processing Dependency: liblz4.so.1 for package: systemd-libs-219-57.el7.i686
--> Finished Dependency Resolution
Error: Package: systemd-libs-219-57.el7.i686 (base)
           Requires: liblz4.so.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA